Routine maintenance
Incident Report for Chec
Resolved
This incident has been resolved.
Posted Jul 02, 2020 - 20:49 UTC
Investigating
We're doing some routine maintenance on the Chec Dashboard to improve your user experience. All other services are operational. Sorry for any inconvenience.
Posted Jul 02, 2020 - 20:31 UTC
This incident affected: Dashboard.