Error accessing billing section
Incident Report for Chec
Resolved
This incident has been resolved.
Posted Jan 13, 2020 - 23:06 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 13, 2020 - 20:31 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jan 13, 2020 - 20:02 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 13, 2020 - 20:02 UTC
This incident affected: Dashboard.