Slow responses from the API
Incident Report for Chec
Resolved
This incident has been resolved.
Posted Jan 12, 2021 - 20:34 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 12, 2021 - 18:38 UTC
This incident affected: API, Chec Spaces, and Checkout.