Slow responses from the API
Incident Report for Chec
Resolved
This incident has been resolved.
Posted May 29, 2021 - 19:55 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 29, 2021 - 19:52 UTC
Investigating
We are currently investigating this issue.
Posted May 29, 2021 - 19:48 UTC
This incident affected: API, Dashboard, Chec Spaces, and Checkout.