Maintenance on orders list view
Incident Report for Chec
Resolved
Changes have propagated and the list view is operating as normal again.
Posted Nov 10, 2020 - 20:04 UTC
Investigating
We are deploying some updates to make the orders view more performant. It is likely to be unavailable for up to 5 minutes while these changes propagate.
Posted Nov 10, 2020 - 20:00 UTC
This incident affected: Dashboard.